TROUBLESHOOTING

"Unfortunately, Your Login Changes Weren't Successful. Please Double-Check What You've Entered And Try Again." When Editing Login Info

Issue

Getting the error ""Unfortunately, Your Login Changes Weren't Successful. Please Double-Check What You've Entered And Try Again." when attempting to edit the login information for your account, including editing the email address.
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Objective

Environment

  • GoToMeeting
  • GoToWebinar
  • GoToTraining
  • OpenVoice

Procedure

Answer

Cause

You will receive this message if the email address you are trying to use already has an account associated with it.

Resolution

Please contact Customer Care directly so that we can assist further with this issue. Our support numbers can be found here: http://support.citrixonline.com/en_US/Meeting/phone

Additional Information