TROUBLESHOOTING

Can't Access The My Meetings, My Webinars, or My Trainings Pages In Chrome

Issue

When I click the GoToMeeting GoToWebinar GoToTraining OpenVoice link at the top of my My Account page nothing happens or I get a spinning wheel in Chrome.

Objective

Environment

  • GoToMeeting
  • GoToWebinar
  • GoToTraining
  • OpenVoice
  • Chrome

Procedure

Answer

Cause

This can happen if Chrome thinks you are actively logged into a different account, or a previous login session did not end cleanly.

Resolution

  1. Click the Chrome menu
  2. Click History
  3. Click History again
  4. Click Clear browsing data... button
  5. Select the time period from the Obliterate the following items from:
  6. Check boxes next to Browing History, Cookies, Cached images and files
  7. Click Clear browsing data
  8. Log in to your account

Additional Information