TROUBLESHOOTING

Error: "Sorry, GoToMyPC cannot be started at this time. Please try again in a few moments"

Issue

Error "Sorry GoToMyPC cannot be started at this time. Please try again in a few moments" when trying to connect to a host computer

Objective

Environment

  • GoToMyPC
  • Windows client computer
  • Shared %temp% folder
  • Incorrect permissions on %temp% folder

Procedure

Answer

Cause

The %temp% folder may be shared or the user may not have read/write permissions for this folder.

Resolution

This error can be caused by the GoToMyPC viewer files being erroneously "in-use" according to Windows. If a reboot of the Client doesn't resolve it, follow the steps below from the Client PC:

Run the Launcher Error Tool


  1. Download the tool here .
  2. Extract Citrix_Launcher_Error_2006_Fix.zip
  3. Right click on Citrix_Launcher_Error_2006_Fix.bat
  4. Select Run as administrator
  5. Wait while a command prompt window appears and disappears
  6. Attempt to connect to the computer again


Manually Disable Sharing of Temp Folder


  1. Hold the Windows key and press R
  2. Type %temp% in the run window
  3. Navigate back one folder
  4. Right click on the Temp folder
  5. Select Share or Share With
  6. Click Stop Sharing or select Nobody
  7. Click Done

Additional Information

Note: Depending on your settings, additional steps my be required to disable folder sharing.
You may need to repeat these steps for the folder CitrixLogs in the temp.