TROUBLESHOOTING

Why do I have a "Waiting for Organizer" screen but others are connected already?

Issue

I have a "Waiting for Organizer" screen but I can confirm that other people are joined into the live session.

Objective

Environment

  • GoToMeeting
  • GoToWebinar
  • GoToTraining

Procedure

Answer

Cause

The most common cause for this issue is joining a different session than the one being hosted. If you have multiple confirmations for several recent or upcoming events please check the meeting, webinar, or training ID number to confirm what session you are attempting to join.

Resolution

  1. Compare the Meeting, Webinar or Training ID with the others who are already logged into the session
  2. If it does not match, exit the session you are connected to
  3. Join the intended session via appropriate product join page

Additional Information

Product join pages: www.joingotomeeting.com, www.joinwebinar.com or www.jointraining.com